Fix: WordPress Gravatar macht E-Mail Adressen öffentlich

Geschrieben von:

Gravatar LogoErstmal vielen Dank an die liebe Lena, die mich auf dieses Problem aufmerksam gemacht hat. Sie war es auch, die mich nun dazu gebracht hat, darüber einen eigenen Beitrag zu schreiben. Denn wir denken beide, das Problem ist nicht nur in meinem Fall vorhanden gewesen. Bestimmt suchen viele andere Webmaster auch nach Lösungen dafür. Und da man auf Google über dieses Thema so gut wie nichts passendes findet, starte ich nun mal diesen extra Beitrag.

Um folgende Problematik geht es hier:

Leider musste ich heute Gravatar (A Globally Recognized Avatar) wieder deaktivieren! Was mir sehr weh tut, da ich diese bunten Bildchen sehr mochte. Aber tatsächlich hat Gravatar in diesem Blog hier die angeblich nicht veröffentlichten E-Mail Adressen der Kommentierer als ALT=““ Text im Code angezeigt. Ich habe stundenlang nach einer Lösung gegoogelt, aber nichts passendes darüber gefunden. Also habe ich als einzige logische Lösung die Avatarbilder wieder deaktiviert und siehe da, die E-Mail Adressen sind nicht mehr im Quelltext sichtbar!

Auch das Installieren der Plugins “Avatar Privacy” und “FV Gravatar Cache” hat an dem Problem nichts geändert. Letzteres hat zwar die Gravatare erfolgreich in ein Cache Verzeichnis auf dem Server gespeichert und die IMG URL mit dem MD5 Hash vom Gravatar Server ersetzt, aber das verflixte ALT=““ Attribut mit der E-Mail Adresse war immer noch öffentlich im Code (Quelltext) einsehbar. 😥

Habt ihr eine Idee, wie man die Avatarbilder aktiv haben kann und die E-Mail Adresse nicht im Code auftaucht ? Oder hab nur ich dieses Problem mit Gravatar ? Weil normal ist das ja nicht, dass WordPress die E-Mail veröffentlicht.

Ich habe zwei Bekannte per E-Mail um Rat gefragt, die auch WordPress verwenden und sich in der Materie sehr gut auskennen. Martin hat mir bereits geantwortet und empfohlen, das Plugin “FV Gravatar Cache” zu testen. Leider hat es nicht geklappt (wie oben bereits beschrieben). Alex hat sich auch schon gemeldet und geschrieben, dass er seinen Code gecheckt habe und dort werden keine Mail-Adresse angezeigt. Daher ist es wirklich ein Problem bei mir. Leider kann er mir auf Anhieb nicht helfen und kann mir nur das bekannte WordPress-Forum ans Herz legen.

Desweiteren habe ich mein Problem auch in zwei Google+ Communities (BloggerNetzwerk und SEO auf Deutsch!) gepostet. Und auch schon die erste interessante Antwort erhalten. Hier ist sie: Gravatar „erzeugt“ ja keine <img> tags, sondern stellt lediglich URLs bereit. Dementsprechend kommt das ALT-Attribut anderswoher. Zum Beispiel aus einem Plugin oder dem aktiven Theme. (vielen Dank an Torben L. für die schnelle Response) Da alle meine Plugins auf dem neuesten Stand sind, liegt es wohl an meinem aktiven Theme, welches übrigens schon uralt ist und keine neue Version gibt.  😳

Erstmal vielen Dank für die vielen Tipps, die ich bekommen habe. Auch dir Martin vielen Dank für deine Mühe und den unzähligen E-Mails die wir wegen diesem Problem hin und her geschrieben haben. Dein letzter Vorschlag, die Plugins „Jetpack“ und „All in One SEO Pack“ zu deaktivieren brachte zwar keinen Erfolg. Doch die grundlegende Idee, dass es an einem installierten Plugin liegt, war letztendlich gar nicht so falsch. Durch die G+ Community „WordPress Deutschland“ in der ich auch das Problem ausführlich beschrieb, bekam ich nämlich folgende hilfreiche Antwort von Thomas S. „Die Email-Adresse im Alt-Attribut kommt nicht von WordPress und auch nicht von Gravatar. Du hast irgendein Plugin aktiviert, dass diese Funktion überschreibt. Schalte alle Plugins ab.“

Gesagt getan, ich deaktivierte zunächst alle Plugins. Und beim nächsten Aufruf eines Artikels mit vielen Kommentaren, bekam ich erstmal Panik. Denn es kam folgende Fehlermeldung: „Nichts gefunden. Sorry, aber du suchst gerade nach etwas, was es hier nicht gibt.“ Nach und nach aktivierte ich wieder ein Plugin nach dem anderen. Und siehe da, die Fehlermeldung war weg und der Artikel wurde wieder angezeigt. Ich habe danach sofort den Quelltext gecheckt und tatsächlich, es waren keine E-Mail Adressen zu finden. Jetzt wollte ich es genau wissen und habe weiter gesucht an welchem Plugin es letztendlich gelegen hat. Und ich habe den Übeltäter gefunden! Es war das Plugin „Easy Author Image“ (Version 1.5) Pluginbeschreibung: Adds an author image uploader to your profile page. Upload an author image right from your profile page with the click of a button. *Lösung* Einfach deaktivieren und/oder komplett löschen und die E-Mail Adressen werden nicht mehr als ALT-Tag nach der Gravatar URL im Code veröffentlicht!

1

Über den Autor:

Hi, ich bin Jörg Klopsch - freiberuflicher Online Redakteur bei Tippe New Media UG & Co. KG und Blogger auf GrabFreeGames.net ... Dies ist meine erste englisch-sprachige Internetseite über kostenlose Spiele im Internet. (hauptsächlich für die Spieleplattform Steam) mit teilweise über 2.000 Besucher täglich!!! Du findest mich auch auf Google+, Facebook, Twitter, Instagram, LinkedIn und Xing
  Verwandte Beiträge

Kommentare

  1. Thomas  März 23, 2014

    Hi Jörg, ich habe jetzt bei mir noch mal nachgesehen. Bei mir sind die ALT-Attribute der Gravatar-Logos leer. Da stehen keine Mailadressen drinnen.

    Somit könnte das wirklich an Deiner Installation oder an dem Theme liegen.

    LG Thomas
    Thomas kürzlich veröffentlicht…Reisen-Fotografie hat nun auch eine Google+ SeiteMy Profile

    antworten

Schreibe einen Kommentar


CommentLuv badge